sábado, 13 de junio de 2015

Solución sprintf y ADC DelSig 20 Bit PSoC 5LP - CY8CKIT059


Se describe la solución para hacer funcionar la instrucción sprintf en Creator 3.1 y 3.2, implementado en un conversor análogo digital Delta Sigma de 20 bits.

La solución para hacer funcionar la instrucción sprintf es:





1. - A la izquierda clic derecho al proyecto y entrar en build settings
    -  Clic en linker
   -  Command line y luego en custom flags poner -u_printf_float
   -  Aplicar y aceptar.

2. - Acceder al archivo de configuración de pines .cydwr
    - Pestaña sistema
    - Cambiar Heap Size a 0x200
    - Compilar
Con esto debería funcionar la instrucción sprintf.

La librería de la LCD es :

http://www.mediafire.com/download/yrrmxwh5uyhzf6h/CharLCDmp_Demo3.zip

Únete a  nuestra Comunidad en Facebook :
https://www.facebook.com/groups/DigitalProjectsUD/



6 comentarios:

  1. Gracias! Si bien tengo el kit -05, me funciono. Me gustaria ver por acá un tutorial sobre como programar correctamente el psoc 5lp, si bien soy mas de hard que de soft, me las arreglo pero creo que podría hacerlo mejor. Gracias nuevamente y excelente web! Saludos desde BsAs, Argentina - Edgardo

    ResponderEliminar
  2. Hola Brayan, todo bien? Mira, podrias subir el código de este ejemplo (Solución sprintf y ADC DelSig 20 Bit PSoC 5LP - CY8CKIT059)? Gracias y saludos!

    ResponderEliminar
  3. Hola Brayan! Hice el proyecto sin problemas, me aparece la leyenda Voltaje: pero por alguna razon me queda el led azul encendido (la que esta en la tarjeta target). Programe lo que progame siempre me queda ese led encendido! Hay manera de limpiar el contenido del psoc? Dejarlo sin nada adentro me refiero. Gracias!

    ResponderEliminar
  4. Una consulta, logre que se apagara el led azul, eso quiere decir que el puerto 2.1 no se puede utilizar? Porque yo justo habia usado ese puerto conectando uno de los bits de datos del lcd, cambie la configuracion y se apagao. Que puertos NO se pueden usar? Gracias

    ResponderEliminar
    Respuestas
    1. Hola Edgardo!, si eso es lo que te iba a decir, debes revisar que no tengas algo conectado al pin que esta asignado por defecto al LED, no es que este pin no se pueda usar, se puede usar correctamente sin ningún problema, lo que pasa es que cuando conectas algo a este pin tienes que tener en cuenta que también esta conectado al LED y que si le ingresas un 1 Lógico al pin este se vera reflejado en el LED, y así pasa con todos los pines que están asignados por defecto en la tarjeta, pero estos se pueden usar sin ningún problema.

      Eliminar